Author Topic: Is Crocotile tested well on Mac?  (Read 1198 times)

Daigo

  • Newbie
  • *
  • Posts: 4
Is Crocotile tested well on Mac?
« on: April 23, 2016, 08:28:06 AM »
Hi, Alex

I just bought this tool to see if we should use this for our new game. So far I see potential in this tool, however I noticed there are a lot of weird behaviors(bugs), such as:

1. Delete key does not work, I need to press "Fn + Delete"
2. Undo/Redo randomly stop working, I cannot figure out the repro step yet.
3. Sometimes, even after toggling from edit view to tile view, the 3D scene still shows selectors for vertex [screen shot 1]. I had no way to recover from this state.. actually after a while, all the objects are gone from the screen, even the crosshair [screen shot 2]

I guess Mac is not your primary OS, but almost of all of my developer friends are using Mac, so stability and usability on Mac matter to us.

I am using Crocotile3D_v1.2.5_osx

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 327
Re: Is Crocotile tested well on Mac?
« Reply #1 on: April 23, 2016, 05:53:54 PM »
Thanks for the info!
Have you tried rebinding the "remove/delete" action in the button settings? Maybe it will recognize the correct key if you try to rebind it.
I'm not sure about the undo/redo stopping. Does it not work even if you click the undo/redo buttons instead of using the keyboard?
Verts and faces remain selected even if you go into draw mode. You can press ctrl+d to deselect while in draw mode. The green faces signify you're in Active selection mode (used for tile splitting or for editing only those verts/faces), and can be exited by pressing Enter while in edit mode. I'm not sure why everything is disappearing.
I don't own a mac, but I'll try to run some tests on a publicly available machine.

Daigo

  • Newbie
  • *
  • Posts: 4
Re: Is Crocotile tested well on Mac?
« Reply #2 on: April 24, 2016, 02:46:34 AM »
Thanks, yeah please definitely checkout on Mac how it acts out. I see so much potential in this tool, so I will try to g

> Keybinding
Yeah, I will try

> Undo/Redo
When it stops working, the GUI button does not take any effect as well.

> ctrl+d to deselect while in draw mode
It did not work in my case. I am suspecting there is something crashing internally.. Are you using any scripting language to build the tool? Perhaps there is a null reference exception or that sort of things..