Author Topic: Paintbrush stroke choppy with Wacom Tablet *Fixed*  (Read 1550 times)

Rosalie

  • Newbie
  • *
  • Posts: 13
    • 3DSauce.com
Paintbrush stroke choppy with Wacom Tablet *Fixed*
« on: February 11, 2016, 06:59:58 PM »
Hey everyone,

I came across this problem using my Wacom Tablet and playing around with the painting tools. It so happen that I found the solution, so I figure I would explain it here in case anybody else had this issue. I don't think this is specific to Crocotiles too so this might fix a lot of pain for other painting tool users in the future! 

The problem:
Using a tablet and a pen, when painting a stroke, the first milliseconds of the stroke will look like the computer is buffering (if you hold the pen down, you might notice that there is an actual loading icon). The paint is going to appear from the point you clicked to the point where your cursor is now (since you moved it doing a fluid motion) And create an ugly line. This makes it feel like the paintbrush is lagging, but only for the first millisecond.

This only happens with the pen. If you use a mouse, the stroke will appear immediately and be applied fluidly. 

The solution:
This is due to a feature called Windows Ink. To disable it, go to your Wacom Tablet drivers, in the Pen tab, and click on Mapping. At the bottom of the pop up, Un-tick "Use Windows Ink" and Voila!

At first I taught it was specific to Crocotiles, since doing the same motions in Photoshop did not have the same effect. But I had a hunch this was due to something else since it wasn't the first time I noticed a painting program having this issue. So there you have it, I hope this helps!

here is an example of what it looks like when you paint:

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 327
Re: Paintbrush stroke choppy with Wacom Tablet *Fixed*
« Reply #1 on: February 11, 2016, 07:42:57 PM »
Thanks for the tip!
I remember having this issue in the past.

I just did a search and I think the way I solved it was based on these instructions:
"
Open the Control Panel and type "tablet" into the search field
Select "Pen and Touch" settings
From the "Pen Options" tab, select "Press and Hold" and click "Settings..."
Make sure "Enable press and hold for right-clicking" is unchecked.
Click OK.
Select the "Flicks" tab
Make sure that "Use flicks to perform common actions quickly and easily" is unchecked.
Click Apply, and OK.
"

So that might be another way to solve the issue.

Rosalie

  • Newbie
  • *
  • Posts: 13
    • 3DSauce.com
Re: Paintbrush stroke choppy with Wacom Tablet *Fixed*
« Reply #2 on: February 11, 2016, 07:47:48 PM »
Hmm now to think of it, I might of played with those as well... Darn I suck at bug testing !

If it ever happens again, I'll try that out, Thanks a bunch!