Author Topic: BUG : Lost all my work :( [SALVAGED!]  (Read 1219 times)

Brian

  • Newbie
  • *
  • Posts: 16
BUG : Lost all my work :( [SALVAGED!]
« on: January 12, 2016, 08:20:11 AM »
Did a marathon session with Crocotile last weekend up to tonight and was making some big headway with creating a large dungeon..

Not entirely sure what happened but I noticed that my textures weren't snapping to the grid correctly for some reason so I saved and closed the program. When I opened it back up my save file had no objects in it anymore. The build was made up entirely of objects with no faces in the scene, so the scene is completely blank. I'm wondering if this maybe played a role in the bug, since I also noticed I wasn't able to export if I didn't have any non-object faces in the scenes.

I'm attaching the file I was making. It seems to still contain the object data (I see the object names when viewed in a text editor), but nothing appears when I load it into Crocotile.

(File link PMed)

I imagine it's not salvageable, but maybe will help figure out what went wrong.

Edit: Was able to salvage my work! HUZZAH! I created a new Crocotile scene, saved it out, grabbed all the data past "prefabs" in my corrupt file and pasted it into the new file. Loaded in my existing spritesheet and it seems to be back to where it was! Gonna PM the file link to you Alex, in case you want to look into what might have happened.
« Last Edit: January 12, 2016, 08:31:11 AM by Brian »

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 327
Re: BUG : Lost all my work :( [SALVAGED!]
« Reply #1 on: January 12, 2016, 03:54:37 PM »
Hi Brian,
Sounds like you ran into the bug I fixed recently, so you're probably using a version earlier than 1.2.0b
If you download and try 1.2.0b, it should work. I tried loading your file with it and it loaded fine.
Let me know if this is the case. Thanks

edit: I also tried loading it in previous version just to make sure, and it didn't load in that version. So updating to the new version should prevent future problems!
« Last Edit: January 12, 2016, 04:34:58 PM by Alex »

Brian

  • Newbie
  • *
  • Posts: 16
Re: BUG : Lost all my work :( [SALVAGED!]
« Reply #2 on: January 12, 2016, 05:12:16 PM »
Ahh! I think I missed 1.2.0b by a day, hah! That's definitely gotta be it. Will grab the newest version when I get home and give it a test. Thanks!