Author Topic: Issue when launching: requesting assistance  (Read 81 times)

SirSpaceAnchor

  • Newbie
  • *
  • Posts: 9
    • View Profile
Issue when launching: requesting assistance
« on: January 12, 2019, 09:53:02 AM »
Hey all! I decided to pick up the full version of the program a little bit ago and have run into a bit of an issue.

running Linux x64

Problem 1:

UserName@pop-os:~/Crocotilex64$ ./crocotile3d
[17309:17309:0112/024543:ERROR:sandbox_linux.cc(336)] InitializeSandbox() called with multiple threads in process gpu-process
UserName@pop-os:~/Crocotilex64$

this occurs when I attempt to launch the 64 bit version.

Problem 2:

UserName@pop-os:~/Crocotile$ ./crocotile3d
./crocotile3d: error while loading shared libraries: libnss3.so: cannot open shared object file: Error 40
UserName@pop-os:~/Crocotile$

this occurs when attempting to launch normal version.

Any ideas all?

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #1 on: January 13, 2019, 06:10:26 AM »
I'm not that familiar with linux, and when I last messed with it, I couldn't figure out a way to get crocotile to work on it. There wasn't much documentation on how to package a nwjs app for it at the time- I need to find some clear instructions on that process.

SirSpaceAnchor

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #2 on: January 13, 2019, 06:30:30 AM »
Thanks for the reply, I know my way around linux well enough. Is there any way I could compile it myself? maybe I'd be able to get a fix working?

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #3 on: January 13, 2019, 04:08:17 PM »
Okay,
Here are the linux project files in a zip: https://1drv.ms/u/s!AhHSZHEulqh_ghs6UtVLwiQ8EPT9
And you'll also need the 0.14.7 NWJS files to run it: https://dl.nwjs.io/v0.14.7 (nwjs-v0.14.7-linux-ia32.tar.gz or nwjs-v0.14.7-linux-x64.tar.gz)
Here is some documentation: http://docs.nwjs.io/en/latest/For%20Users/Package%20and%20Distribute/#linux
You might be able to run it without creating a package to distribute, but if you manage to create one let us know the steps!

SirSpaceAnchor

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #4 on: January 14, 2019, 09:28:01 AM »
I have a theory it is a compatibility issue when running an earlier version of NW.js, on a more up to date system? If that is not the case then I have literally zero idea what the issue would be here.

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #5 on: January 14, 2019, 06:13:00 PM »
That could be the case. The reason I had stuck to 0.14.7 is because I was using an older operating system of windows, and newer versions would not run on my computer. I've since updated, so I should be able to test newer versions now.
I just tried to run it with the latest nwjs on windows, but it immediately closes when run, so it seems like I'll need to go back and see which is the latest version that works and check what changed afterwards, etc, and see if I can bring it up to date.

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #6 on: January 14, 2019, 06:25:43 PM »
Okay, I looked a bit more into it, and I think part of the reason it crashes for newer versions is because some compiled files aren't compatible with different versions of nwjs. So I'll have to refresh myself on how to do all that. I'll also see if I can get a virtual machine setup with linux- and experiment with it when I get some time.

SirSpaceAnchor

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #7 on: January 14, 2019, 07:33:22 PM »
Thank you for looking into it, I'm hopeful that we may somehow be able to resolve this issue.

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #8 on: January 15, 2019, 12:06:25 AM »
I have it working on windows10 now with latest nwjs. I still need to get a virtual machine setup with linux so that I can dive into that issue. I'll try to get the virtual machine up tonight or tomorrow.

SirSpaceAnchor

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #9 on: January 15, 2019, 01:57:20 AM »
Great to hear, let me know if I can be of any assistance, I installed nwjs on a fresh install of POP_OS 8.10, which is a fairly nice Ubuntu flavor.

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #10 on: January 15, 2019, 06:03:49 PM »
I have it running inside a linux virtual machine now.
To run it, download and extract the files, then run the crocotile file in the terminal.
I guess you go to the folder location in the terminal and then type ./crocotile to run it.
Here's the download: https://1drv.ms/u/s!AhHSZHEulqh_ghzrEA1NwtdzArL6
If it works for you, i'll officially upload it to the itch.io page.
Let me know if there's any bugs, etc- I haven't fully tested this version.

SirSpaceAnchor

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #11 on: January 15, 2019, 06:38:58 PM »
Thanks! I will keep you posted, seem to still get this error;

./crocotile: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory

But I'm gonna do some digging.

SirSpaceAnchor

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #12 on: January 15, 2019, 06:47:57 PM »
Ok, fixed that error, by creating a symlink to libnss3.so. have a new issue now!

./crocotile: error while loading shared libraries: libnss3.so: wrong ELF class: ELFCLASS64

here we go again!  :P

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #13 on: January 15, 2019, 06:58:12 PM »
Should be noted that the linux I ran was 32bit .. so maybe that's an issue?
I'll try making a 64bit version now since I know the steps to take.

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 320
    • View Profile
Re: Issue when launching: requesting assistance
« Reply #14 on: January 15, 2019, 07:45:22 PM »
alright, here is the 64bit version: https://1drv.ms/u/s!AhHSZHEulqh_gh4Zx_4IcID6qKDW
Maybe that will fix the issue?