Author Topic: Clicks aren't registering  (Read 1651 times)

Polyducks

  • Newbie
  • *
  • Posts: 22
    • Polyducks Website
Clicks aren't registering
« on: November 03, 2016, 10:03:49 PM »
Hi there,

Just loaded the new version of the tool. After a short period of use (perhaps 3 or 4 actions) it stops registering clicks. That includes placing tiles in draw mode or selecting them using edit mode. It doesn't appear to register shortcuts either - ignoring things like the tab key and c key.

Hi and thanks for making crocotile3D!

-Ben

Polyducks

  • Newbie
  • *
  • Posts: 22
    • Polyducks Website
Re: Clicks aren't registering
« Reply #1 on: November 03, 2016, 10:04:35 PM »
p.s. I'm using windows 8

Polyducks

  • Newbie
  • *
  • Posts: 22
    • Polyducks Website
Re: Clicks aren't registering
« Reply #2 on: November 03, 2016, 10:09:50 PM »
Looking at it, I'm working on a much older file. I've tried building using the default tileset and that doesn't appear to cause the issue. Is there a way to upgrade/repair the file I'm working on?

Polyducks

  • Newbie
  • *
  • Posts: 22
    • Polyducks Website
Re: Clicks aren't registering
« Reply #3 on: November 03, 2016, 10:17:33 PM »
Nope, none of those things. Sorry for the long winded post.

It doesn't like it when I alt+tab out of the editor! Why does this happen?

Polyducks

  • Newbie
  • *
  • Posts: 22
    • Polyducks Website
Re: Clicks aren't registering
« Reply #4 on: November 03, 2016, 10:22:22 PM »
Temporary fix:

For anyone else having problem with this - when you alt+tab back into the program, you can press 'alt' and it'll resume functionality.

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 327
Re: Clicks aren't registering
« Reply #5 on: November 03, 2016, 10:52:36 PM »
Thanks for the info- this is related to the way the key binding system works. It stores which keys have been pressed. If the program loses focus while keys are pressed, the key binding system might think they are still pressed. So then when you try to perform other actions they might not work because it is checking the keys pressed down, etc.
I'll look into this some more and see if I can fix it.

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 327
Re: Clicks aren't registering
« Reply #6 on: November 04, 2016, 07:48:21 AM »
Alright, I managed to implement a fix for this. It will be applied in the next update (v1.2.7). I hope to have that out in a few days or so.

Polyducks

  • Newbie
  • *
  • Posts: 22
    • Polyducks Website
Re: Clicks aren't registering
« Reply #7 on: November 05, 2016, 12:08:52 PM »
Excellent! Thanks Alex :)