Author Topic: Tile gaps when imported.  (Read 1393 times)

jameshark

  • Newbie
  • *
  • Posts: 4
    • View Profile
Tile gaps when imported.
« on: June 14, 2016, 11:05:29 AM »
I was wondering if there is an explanation to why gaps appear between the tiles when I export the obj to another program such as Blender or 3DSmax. From what I can tell, the textures aren't fitted properly to the model and other tile textures are bleeding into each other.

I hope there is a way around this!


Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 305
    • View Profile
Re: Tile gaps when imported.
« Reply #1 on: June 14, 2016, 05:52:01 PM »
I can't really see what is being described in the image since the image isn't at original size.
Are the programs smoothing the texture, and thus blending edges of tiles? I've imported to 3dsmax before and I haven't experienced this issue you describe. I'll check again though..

edit: I can't seem to reproduce the issue. Do you have a .crocotile file that exhibits the issue that I can test with?
« Last Edit: June 14, 2016, 06:06:25 PM by Alex »

jameshark

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Tile gaps when imported.
« Reply #2 on: June 14, 2016, 07:21:19 PM »
Thanks for responding!

Sorry about the small image size, here's the full size screenshot: http://i.imgur.com/bOvWBam.png

Here is the crocotile file of the model too: https://drive.google.com/open?id=0B-PCM71maC_fM2p4RGloVWFmZlE

I'll try finding a solution to why it's come out this way too, I appreciate the help!

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 305
    • View Profile
Re: Tile gaps when imported.
« Reply #3 on: June 14, 2016, 09:28:09 PM »
I checked it in 3dsmax, and I could see some bleeding of the texture, but when I set the Filtering to None on the texture, it looked perfect.

So I think it is just due to you texture settings.
Hope that helps you!

jameshark

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Tile gaps when imported.
« Reply #4 on: June 15, 2016, 09:36:38 AM »
I was able to turn of the anti-aliasing in the preferences and it fixed everything!

Thanks for the help.

pkorzeniewski

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Tile gaps when imported.
« Reply #5 on: July 01, 2016, 09:36:10 PM »
I've a similar problem - using this texture:



The bottom edge is antialiased and blends into another tile:



Which results in this: (tested in several applications)


Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 305
    • View Profile
Re: Tile gaps when imported.
« Reply #6 on: July 02, 2016, 12:39:27 AM »
That's due to the render settings of a texture in the corresponding application. You'll need to set the filtering to none or nearest neighbor.
https://en.wikipedia.org/wiki/Texture_filtering
Or you can design your textures in a way so that tiles don't rest against contrasting tiles.

pkorzeniewski

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Tile gaps when imported.
« Reply #7 on: July 02, 2016, 09:07:31 AM »
I've tried with filtering set to none and nearest in WebGL but the problem is still present.. Have you noticed how the bottom UV edge is blurred? Maybe this has something to do with the UV being not precisely mapped?

Alex

  • Administrator
  • Sr. Member
  • *****
  • Posts: 305
    • View Profile
Re: Tile gaps when imported.
« Reply #8 on: July 03, 2016, 03:48:40 PM »
Can you provide some steps for me to reproduce this? I can only assume what you're doing, but if I have some steps to follow, then I could test it on my end and perhaps figure out the problem. Which apps are you using? How are you testing it in webgl?

pkorzeniewski

  • Jr. Member
  • **
  • Posts: 50
    • View Profile
Re: Tile gaps when imported.
« Reply #9 on: July 04, 2016, 10:47:34 AM »
I've found this blog post on rendering pixel art textures in WebGL: https://medium.com/recreating-megaman-2-using-js-webgl/uv-maps-and-tiled-pixel-art-6aaeaaedefb2#.i7mljrfdz - in short this isn't a problem with Crocotile, I just need to prepare textures in a special way :)