Recent Posts

Pages: [1] 2 3 ... 10
1
Support / Re: Cannot launch Crocotile 3D (Linux)
« Last post by Alex on October 21, 2017, 03:37:26 AM »
wow, really? I'm not sure how I overlooked something like that. Maybe when I transitioned to the newer nw.js version I somehow overlooked those files for linux.
Thanks for discovering that!
2
Support / Re: Cannot launch Crocotile 3D (Linux)
« Last post by DarckPenguin on October 20, 2017, 11:33:25 PM »
Just got 1.2.9 working perfectly.

The issue is that you have files that are included in the Windows build, but missing from the Linux build:

icudtl.dat
nw_100_percent.pak
nw_200_percent.pak
resources.pak

Once I downloaded the Windows version of 1.2.9 and copied those files over, the Linux version of 1.2.9 started right up. 
3
Support / Re: Cannot launch Crocotile 3D (Linux)
« Last post by Alex on October 20, 2017, 02:51:33 PM »
Thanks, that might be due to a temporary fix I implemented in 1.2.9 designed to remove a file at the start of the application.
I'm also thinking the other issue might be related to the .desktop file that linux uses to run the program.
4
Support / Re: Cannot launch Crocotile 3D (Linux)
« Last post by DarckPenguin on October 20, 2017, 06:44:36 AM »
If it helps you debug, I did try downloading and running the 32-bit version of 1.2.9, and it gave me a different error in the console, rather than segfaulting:

Code: [Select]
[1020/004134:ERROR:icu_util.cc(157)] Invalid file descriptor to ICU data received.
[1020/004134:FATAL:content_main_runner.cc(677)] Check failed: base::i18n::InitializeICU().
#0 0x0000f240425a <unknown>
#1 0x0000f241f74d <unknown>
#2 0x0000f23cd825 <unknown>
#3 0x0000f23cc5ce <unknown>
#4 0x0000f1e0b05a ChromeMain
#5 0x0000565ed778 <unknown>
#6 0x0000f13ab7c3 __libc_start_main

Aborted (core dumped)

EDIT: I then got past this inital error by copying in icudtl.dat from Chrome's data directory to the Crocotile 3D directory, and this is the new output:

Code: [Select]
[29901:29901:1020/004900:ERROR:resource_bundle.cc(751)] Failed to load /home/kforney/.config/itch/apps/Crocotile 3D/nw_100_percent.pak
Some features may not be available.
[29901:29901:1020/004900:ERROR:data_pack.cc(163)] Entry #56 in data pack points off end of file. Was the file corrupted?
[29901:29901:1020/004900:ERROR:resource_bundle.cc(751)] Failed to load /home/kforney/.config/itch/apps/Crocotile 3D/resources.pak
Some features may not be available.
[29899:29899:1020/004900:ERROR:resource_bundle.cc(751)] Failed to load /home/kforney/.config/itch/apps/Crocotile 3D/nw_100_percent.pak
Some features may not be available.
[29899:29899:1020/004900:ERROR:data_pack.cc(163)] Entry #56 in data pack points off end of file. Was the file corrupted?
[29899:29899:1020/004900:ERROR:resource_bundle.cc(751)] Failed to load /home/kforney/.config/itch/apps/Crocotile 3D/resources.pak
Some features may not be available.
[29899:29899:1020/004900:ERROR:component_loader.cc(169)] Failed to parse extension manifest.
Segmentation fault (core dumped)

So, back to segfaulting, but with more output... but at least the older version works!  :D
5
Support / Re: Cannot launch Crocotile 3D (Linux)
« Last post by DarckPenguin on October 20, 2017, 06:37:54 AM »
That version launches correctly.  Thanks for making it available.   :)
6
Support / Re: Cannot launch Crocotile 3D (Linux)
« Last post by Alex on October 20, 2017, 06:26:12 AM »
It might be due to me using a virtual machine to run a 32bit linux, and the change to the nw.js version.
I remade available the older 1.2.6 version of crocotile3d on itch- maybe you can try that to see if it runs.
I'm not that familiar with linux, and I need to get new hardware,etc, so that I can run the appropriate linux,etc. Then I can develop it more suitably.
7
Support / Cannot launch Crocotile 3D (Linux)
« Last post by DarckPenguin on October 20, 2017, 06:05:17 AM »
I cannot launch Crocotile 3D on Arch Linux.  It opens up the main window and a Tileset window, both white, and then crashes in less than a second, with the process outputting code 139 (SIGSEV).  This occurs on all versions available from Itch.

Any assistance would be appreciated.  :)


8
Support / Re: White line between tiles
« Last post by Shuuichi on October 13, 2017, 05:48:46 PM »
I tried messing with blender, but I don't know how to use it, so I couldn't figure out which settings to use.
You need to adjust the settings for the texture or the way it is rendered. It's not any issue with crocotile3d or the outputted files, it's just the way blender or the other programs render the textures. You'd probably be able to find a solution if you ask the blender community and people more epxerienced using that tool.

Ok, I will try there.
9
Support / Re: White line between tiles
« Last post by Alex on October 13, 2017, 05:44:46 PM »
I tried messing with blender, but I don't know how to use it, so I couldn't figure out which settings to use.
You need to adjust the settings for the texture or the way it is rendered. It's not any issue with crocotile3d or the outputted files, it's just the way blender or the other programs render the textures. You'd probably be able to find a solution if you ask the blender community and people more epxerienced using that tool.
10
Support / White line between tiles
« Last post by Shuuichi on October 13, 2017, 03:05:40 AM »
Hello, I get this problem on my 3D softwares while loading exported scene from Crocotile (1.29) into them (blender and zmodeler, I don't have 3dmax so I can't test them there).

Scene in crocotile:



How does it looks in Blender (2.77):



and Zmodeler:



I've tried everything on export window, I get even worst results trying other options.

EDIT: I can add that I'm using two textures in 256x256 resolution each one. I've read here http://c3d.xyz/index.php?topic=159.0 that the problem was related to texture dimension but as I see my textures are not wrong.
Pages: [1] 2 3 ... 10