Crocotile 3D

Crocotile 3D => General => Topic started by: SirSpaceAnchor on January 12, 2019, 09:53:02 AM

Title: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 12, 2019, 09:53:02 AM
Hey all! I decided to pick up the full version of the program a little bit ago and have run into a bit of an issue.

running Linux x64

Problem 1:

UserName@pop-os:~/Crocotilex64$ ./crocotile3d
[17309:17309:0112/024543:ERROR:sandbox_linux.cc(336)] InitializeSandbox() called with multiple threads in process gpu-process
UserName@pop-os:~/Crocotilex64$

this occurs when I attempt to launch the 64 bit version.

Problem 2:

UserName@pop-os:~/Crocotile$ ./crocotile3d
./crocotile3d: error while loading shared libraries: libnss3.so: cannot open shared object file: Error 40
UserName@pop-os:~/Crocotile$

this occurs when attempting to launch normal version.

Any ideas all?
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 13, 2019, 06:10:26 AM
I'm not that familiar with linux, and when I last messed with it, I couldn't figure out a way to get crocotile to work on it. There wasn't much documentation on how to package a nwjs app for it at the time- I need to find some clear instructions on that process.
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 13, 2019, 06:30:30 AM
Thanks for the reply, I know my way around linux well enough. Is there any way I could compile it myself? maybe I'd be able to get a fix working?
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 13, 2019, 04:08:17 PM
Okay,
Here are the linux project files in a zip: https://1drv.ms/u/s!AhHSZHEulqh_ghs6UtVLwiQ8EPT9
And you'll also need the 0.14.7 NWJS files to run it: https://dl.nwjs.io/v0.14.7 (nwjs-v0.14.7-linux-ia32.tar.gz or nwjs-v0.14.7-linux-x64.tar.gz)
Here is some documentation: http://docs.nwjs.io/en/latest/For%20Users/Package%20and%20Distribute/#linux
You might be able to run it without creating a package to distribute, but if you manage to create one let us know the steps!
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 14, 2019, 09:28:01 AM
I have a theory it is a compatibility issue when running an earlier version of NW.js, on a more up to date system? If that is not the case then I have literally zero idea what the issue would be here.
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 14, 2019, 06:13:00 PM
That could be the case. The reason I had stuck to 0.14.7 is because I was using an older operating system of windows, and newer versions would not run on my computer. I've since updated, so I should be able to test newer versions now.
I just tried to run it with the latest nwjs on windows, but it immediately closes when run, so it seems like I'll need to go back and see which is the latest version that works and check what changed afterwards, etc, and see if I can bring it up to date.
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 14, 2019, 06:25:43 PM
Okay, I looked a bit more into it, and I think part of the reason it crashes for newer versions is because some compiled files aren't compatible with different versions of nwjs. So I'll have to refresh myself on how to do all that. I'll also see if I can get a virtual machine setup with linux- and experiment with it when I get some time.
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 14, 2019, 07:33:22 PM
Thank you for looking into it, I'm hopeful that we may somehow be able to resolve this issue.
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 15, 2019, 12:06:25 AM
I have it working on windows10 now with latest nwjs. I still need to get a virtual machine setup with linux so that I can dive into that issue. I'll try to get the virtual machine up tonight or tomorrow.
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 15, 2019, 01:57:20 AM
Great to hear, let me know if I can be of any assistance, I installed nwjs on a fresh install of POP_OS 8.10, which is a fairly nice Ubuntu flavor.
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 15, 2019, 06:03:49 PM
I have it running inside a linux virtual machine now.
To run it, download and extract the files, then run the crocotile file in the terminal.
I guess you go to the folder location in the terminal and then type ./crocotile to run it.
Here's the download: https://1drv.ms/u/s!AhHSZHEulqh_ghzrEA1NwtdzArL6
If it works for you, i'll officially upload it to the itch.io page.
Let me know if there's any bugs, etc- I haven't fully tested this version.
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 15, 2019, 06:38:58 PM
Thanks! I will keep you posted, seem to still get this error;

./crocotile: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory

But I'm gonna do some digging.
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 15, 2019, 06:47:57 PM
Ok, fixed that error, by creating a symlink to libnss3.so. have a new issue now!

./crocotile: error while loading shared libraries: libnss3.so: wrong ELF class: ELFCLASS64

here we go again!  :P
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 15, 2019, 06:58:12 PM
Should be noted that the linux I ran was 32bit .. so maybe that's an issue?
I'll try making a 64bit version now since I know the steps to take.
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 15, 2019, 07:45:22 PM
alright, here is the 64bit version: https://1drv.ms/u/s!AhHSZHEulqh_gh4Zx_4IcID6qKDW
Maybe that will fix the issue?
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 15, 2019, 07:54:18 PM
YES!!!! IT WORKS! You are a god among men! I will post again if I happen to encounter any bugs!
Title: Re: Issue when launching: requesting assistance
Post by: SirSpaceAnchor on January 15, 2019, 08:00:47 PM
Ok so it runs! The console is throwing a bunch of errors, they don't seem to break anything so I think we're alright.

[13800:13800:0115/125850.148834:ERROR:gles2_cmd_decoder.cc(10735)] [.WebGL-0x55c4cb79d6c0]RENDER WARNING: Render count or primcount is 0.
[13800:13800:0115/125850.197646:ERROR:logger.cc(47)] Too many GL errors, not reporting any more for this context. use --disable-gl-error-limit to see all errors.
Title: Re: Issue when launching: requesting assistance
Post by: Alex on January 15, 2019, 08:07:56 PM
cool- yeah I get the same errors. I'm not sure why it does that, but based on a quick search it seems that it doesn't matter- things will still work.
Good to know it's working for you now :)